AnsweredAssumed Answered

The version 2.10.5.9075 of PI AF Server 'AFDev' does not support the Legacy (1.x) Notification Feature because the new Notification Rule Feature is enabled error show when trying to add new notification through C# code. we had   AFSdk.dll version is 2.10

Question asked by Bhushan_Sonawane on Oct 9, 2019
Latest reply on Oct 10, 2019 by sraposo

Hi ,

 

The version 2.10.5.9075 of PI AF Server 'AFDev' does not support the Legacy (1.x) Notification Feature because the new Notification Rule Feature is enabled error show when trying to add new notification through C# code. we had 

AFSdk.dll version is 2.10 ?

 

AFNotificationContactTemplate myGroupContactTemplate = PiSystem.NotificationContactTemplates[_groupname];

// Create a Notification Template configured to AutoCreate its Target
AFNotificationTemplate myNotificationTemplate = new AFNotificationTemplate(_analysisName);
myNotificationTemplate.Description = _analysisName;
myNotificationTemplate.AnalysisTemplate = myAnalysis.Template;
myNotificationTemplate.AutoCreate = AFNotificationTemplate.AutoCreateOption.AutoCreate;
AFdb.ElementTemplates.Add(myNotificationTemplate);
AFdb.CheckIn();

// Create a Notification from the Notification Template
AFNotification myNotification = new AFNotification(AFdb, _analysisName, myNotificationTemplate, _element);
myNotification.NotificationContacts.Add(myGroupContactTemplate);


AFdb.CheckIn();

 

 

any please help us on this above problem ?

 

Thanks and regards,

Bhushan

Outcomes