Nandhini8588

PI Tags reading 'Configure' after PI OPC interface restart

Discussion created by Nandhini8588 on Oct 25, 2019

@Hello All,

We have recently configured new PI tags to read data from an OPC interface. Post interface configuration, most of the PI tags were getting good data. However after scheduled reboot of the interface node, the interface got restarted and  we see 'Configure' for most of the tags. We have verified the instrument tags, they are all correct, and there were no changes made by us. We have also checked the data in Matrikon explorer and we have good data there.

 

Initially we did a scan off and on for few PI Points and some of them started getting data. However the tags started reading 'Configure' after the next interface restart.

 

The PI SDK logs on the interface node, gives the below error for each of the tags reading 'Configure'.

AddItems failed for tag xxxxxxx: The ItemID is not syntactically valid (c0040008)

 

I have gone through the KB article KB01201 and PI Square posts associated with the above error, and thought the length of the instrument tag name could be the issue. So I tried giving the Item ID in extended descriptor instead of Instrument Tag. However I could see the same error after tag edits, and the value is 'Configure'.

 

I have tried adding the Item ID within double quotes, and it still doesn't help. I am attaching one of the sample error messages and the exdesc format that was tried. 

Can someone help me on finding what could be the issue here.

 

Also, the OPC interface manual indicates that the max character length allowed for recent versions of API and PI DA is 1023.

Our PI DA version is 3.4.415.1188 and the PI API version is 2018 (2.0.2.5) . So I am not sure why we are facing this issue.

 

Pls note that the PI OPC DA interface version is 2.6.18.2

Any thought/inputs on this issue would be helpful.

 

Thanks,

Nandhini.S

Attachments

Outcomes