AnsweredAssumed Answered

Why PI API for Integrated Security not in default interface installer?

Question asked by Roger Palmen on Nov 22, 2019
Latest reply on Nov 25, 2019 by Roger Palmen

In 2016 the PI Web API for Windows integrated security was introduced, removing the need for PI Trusts for anything.

Now while preparing a new deployment at a client, i noticed all interfaces are still packaged with the 'classic' PI API, and not the newer PI API for Windows Integrated Security. And thus trusts are still needed while we know for >3 years these are less secure and also not required anymore.

 

So why isn't the new API included in the packages?

Now i need another package to install any ICU interface to work without trusts.

Outcomes