AnsweredAssumed Answered

ODBC COnnection to Aspen SQLPlus

Question asked by BarryHu on Mar 3, 2020
Latest reply on Mar 4, 2020 by Roger Palmen

I'm trying to use IP21 SQLPlus query to pull batch data into AF tables.

1. I have IP21 ODBC driver installed on the AF server and System DSN set up:

Connection tested Ok.

 

2. I set up a table connection in PI System Explorer:

Choose OLE DB Provider for ODBC:

Choose the DSN and connection tested Ok

3. Created a Linked Table using that connection with a simple query:

as soon as I click OK I got this error:

I've tried various combination of thing: 32-bit driver, 64-bit driver, 32-bit AF, 64-bit-AF, using connection string instead of table connection, using ADSA or not using ADSA, all got the same result.

4. I download a lightweight ODBC testing tool onto the same machine:

https://www.progress.com/support/evaluation/download-resources/download-tools

https://www.simba.com/blog/testing-driver-odbc-test/

Made the connection and execute the query and got the result just fine:

This lead me to believe it's a PI AF thing...

Called tech support and there's very little information on this. When I called I have not tested the connectivity with the lightweight client yet and with that error it was kind of assumed it's the drive's issue and not an AF issue. Now it looks more like something specific to AF.

 

Hope there's someone out there with experience with IP21 ODBC can shed some light....

Outcomes