AnsweredAssumed Answered

Error when installing PI Datalink 2019 - windows 10

Question asked by Cami_Jean on Nov 16, 2020
Latest reply on Nov 16, 2020 by bbregenzer

Hi,

We've been trying to install PI Datalink on my computer (64-bit windows 10 - office 2010) at my company. However the installation returns the error :

Installation of PI DataLink has failed. Setup return code 1603. InstallThread Error 1603.

 

The error log shows that apparently windows 8.1 is detected event though it's supposed to be windows 10 :

This is NOT Windows Server Core becasue explorer.exe was found here C:\Windows\system32\..\explorer.exe
Windows 8.1  detected.

 

And later :

 

--- >>> Setup Module 6
Loading: 6 (C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\PINS.dll)
C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\PINS.dll version 4.0.0.1
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {E997574C-9855-4CD6-A21F-DD7A836EAED6}. Returned error: 259
Module (PI Network Subsystem Support (PINS) v3.4.435.538) will be installed or upgraded.
--- >>> Setup Module 7
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {9A1A3A9E-DF93-48EF-A658-C052B3148BF9}. Returned error: 259
Module (PI Software Development Kit (PI SDK) x86 2018 SP1 Patch 1 v1.4.7.616) will be installed.
--- >>> Setup Module 8
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {AD7714C6-7563-4CF3-954A-C29093B388ED}. Returned error: 259
Module (PI Software Development Kit (PI SDK) x64 2018 SP1 Patch 1 v1.4.7.616) will be installed.
--- >>> Setup Module 9
Loading: 9 (C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\AFClient_Net35.dll)
C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\AFClient_Net35.dll version 1.0.0.3
Module (PI AF Client .NET 3.5 v2.10.7.283) will be skipped - pretending to be already installed.
--- >>> Setup Module 10
[UNSUPPORTED_OPERATING_SYSTEMS]: 10 = x64
Setup module AFClient_x86_2018_SP3_Patch_2.msi is not supported on WIN81NOSP_X64 operating systems.
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {4EF3B527-049E-4042-94B5-C9E869C740BC}. Returned error: 259
Module (PI AF Client 2018 SP3 Patch 2 v2.10.8.440) is not installed, Reason: operating system is not supported - skip installation.
--- >>> Setup Module 11
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {4EF3B527-049E-4042-94B5-C9E869C740BC}. Returned error: 259
Module (PI AF Client 2018 SP3 Patch 2 v2.10.8.440) will be installed.
--- >>> Setup Module 12
Loading: 12 (C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\VSTOWrapper.dll)
C:\Users\Technique\AppData\Local\Temp\PIDataLink_2019_SP1_Patch_1_\VSTOWrapper.dll version 1, 0, 5, 0
VSTOWrapper> Unable to open Registry-Key SOFTWARE\Microsoft\VSTO Runtime Setup\v4R
Module (Microsoft Visual Studio 2010 Tools for Office Runtime v10.0.60724.0) will be installed.
--- >>> Setup Module 13
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {08A9A3BB-EDF6-4ACC-A7E5-BECDBBABF21C}. Returned error: 259
Module (PI DataLink 2019 SP1 Patch 1 x86 v5.5.2.0) will be installed.
--- >>> Setup Module 14
IsMSIInstalled> Unable to obtain Related Products for Upgrade Code {9F2E228C-D2B6-4D2C-8F4D-28076077B587}. Returned error: 259
Module (PI DataLink 2019 SP1 Patch 1 x64 v5.5.2.0) will be installed.

 

 

We've also tried running the .msi files like advised here : PI AF Client SDK Windows 10 not supported .

The PINS_x64.msi file and the pisdk.msi file ran well, but the pisdk_X64.msi file returned the error attached.

 

Any help or idea on what the problem could possibly be would be greatly appreciated.

 

Thank you very much in advance.

Attachments

Outcomes