Powershell Remoting and PI shutdown/startup scripts

Discussion created by espo89 on Aug 8, 2013
Latest reply on Sep 19, 2013 by RJKSolutions

As Rick put it "he and some colleagues" are trying to work with PI and PowerShell.   Well,  I'm one of those colleagues.   I'm trying to setup a PowerShell script using PowerShell remoting (one of the best ideas in a long time for system management if you ask me) and seem to be have ran into a little problem.   I'm trying to run the shutdown and startup scripts in PI through a remote PowerShell session.   I have the remote session setup with all the right domain based credentials and authentication methods (i.e. everything else I've tried works through this session including the OSI PowerShell cmdlets).  But whenever I go to run those scripts they appear to hang.   I tracked it down to the "piartool" statements.   Went and tried a simple test of setting up the remote session and "piartool -sys -query" which should give me the current state of the server.   What it gives me is "Connection to PInetmgr lost" instead....  This same command runs through powershell when I actually log onto the remote server with the same credentials as I'm setting up for the remote session.




It appears that the PI command line tool (piartool and maybe others) has some issues running through a remote powershell session??  Has anyone every got a remote PS session to be able to run the shutdown/startup scripts?