ygalipeau

issue with pi oledb via a web service

Discussion created by ygalipeau on Jan 14, 2014
Latest reply on Jan 23, 2014 by pingram

good morning

 

i am using PI OLEDB 2010 R3 called from a Web Service

 

if i do some extractions it seems to works fine but as soon as i started to ask more queries successively, i receive at a point in time the following error:

 

A .NET Framework error occurred during execution of user-defined routine or aggregate "ekho_get_PIOLEDB_Data": 

 

System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host

 

System.Net.Sockets.SocketException: 

 

   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

 

System.IO.IOException: 

 

   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

 

   at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)

 

   at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)

 

System.Net.WebException: 

 

   at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)

 

   at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)

 

   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

 

   at EkhoWebServiceSQL.localhost.EkhoService.GetPIOLEDBData(String strQuery, String strServer, String strUser, String strPassword, String strURL)

 

   at StoredProcedures.ekho_get_PIOLEDB_Data(String query, String server, String uid, String pswd, String url)

 

 

 

any idea of what i could look for to fix this?

 

thanks

 

yannick

Outcomes