10 Replies Latest reply on Jul 25, 2017 6:28 AM by wbalbido

    5 | Error  | Unable to get archive data from source PI server

    marco.zoccoli
      Hello, I have a Performance Tag (Device Status) of an interface PI-to-PI, in production enviroment enhanced with: "5 | Error  | Unable to get archive data from source PI server" The same interface, in a different enviroment (dev), work without problem. Can someone explain to me "error 5" and what could be the cause of this mismatch? Regards, Marco
        • Re: 5 | Error  | Unable to get archive data from source PI server

          Hello Marco,

           

          Error # 5 translates "Access is denied" and indicates the interface doesn't have read access to the point. Please check with the PI Server log and / or PI Network Manager statistics for the credentials the interface instance connects with. Afterwards verify with the points security and possibly Database security settings if the connecting identity has read access.

           

          Please let us know if you want to be contacted by a Technical Support Engineer for assistance.

            • Re: 5 | Error  | Unable to get archive data from source PI server
              marco.zoccoli

              Hello Gregor,

               

              Meanwhile, thanks for your reply, I'm doing the checks that you suggested. The strangeness of this interface is that in the last 30 day has had a fluctuating enhancement: form 18/01 to 16/02 every 3 hours:

               

              4 | Intf Shutdown 19/01/2014 4.20.12

               

              1 | Starting | UI 4.5.2.0 19/01/2014 4.20.31

               

              Good 19/01/2014 4.20.31

               

              4 | Intf Shutdown 19/01/2014 7.20.10

               

              1 | Starting | UI 4.5.2.0 19/01/2014 7.20.30

               

              Good 19/01/2014 7.20.30

               

              ...

               

              in that period the tags are properly recorded.

               

              from 16/02 to now every 10sec :

               

              5 | Error | Unable to get archive data from source PI server 17/02/2014 16.35.08

               

              Good 17/02/2014 16.35.18

               

              5 | Error | Unable to get archive data from source PI server 17/02/2014 16.35.18

               

              Good 17/02/2014 16.35.26

               

              5 | Error | Unable to get archive data from source PI server 17/02/2014 16.35.28

               

              Good 17/02/2014 16.35.38

               

              in this period the tags aren't recorded (last timestamp: 16/02)

               

              Is normal this behavior or not?

               

              Thanks for support,

               

              Marco

                • Re: 5 | Error  | Unable to get archive data from source PI server

                  Hello Marco,

                   

                  This doesn't look like normal behavior to me. When starting an interface instance, device status may report statuses like "4 | Intf Shutdown" or "1 | Starting" but not if the instance is running continuously. If the interface is configured for UNIINT Interface level failover, one may see such messages when transitioning but the question remains what's causing the failover. Especially frequent changes between good and bad statuses usually indicate an issue. Causes can be anything starting with a bad piece of hardware, a configuration issue, communication issues ...

                   

                  I'll request a Technical Support Engineer contacting you for troubleshooting. Please have your interface configuration files, Interface versions, log files from the interface node and PI Server logs ready, if possible.

                    • Re: 5 | Error  | Unable to get archive data from source PI server
                      marco.zoccoli

                      Hi Gregor,

                       

                      today i have restart the interface and i see this error:

                       

                      Information, PItoPI, 2/18/2014 3:25:08 PM,"Error -10733 returned from piar_getarcvaluesx(1) call to source PI server PISRVQA.RISORSE.ENEL", Localhost, , 4, UNIINT, , , , 10, , servizi.enel\E3088GMD$, , 8152, PIToPI-, LARTOPI | 4 | 0,

                       

                      I enclose the log where you can see the error.

                       

                      I run the command "telnet PISRVQA.RISORSE.ENEL 5450" and the server responds.-->Work Fine

                       

                      There is something wrong nell'History Recovery.

                       

                       

                       

                      Thanks a lot

                       

                      Regards

                       

                      Marco

                       

                       

                       

                       

                       

                       

                       

                       

                        • Re: 5 | Error  | Unable to get archive data from source PI server
                          marco.zoccoli

                          Hi Gregor,

                           

                          do you have any update / new suggestion?

                           

                          Thanks a lot

                           

                          Regards

                           

                          Marco

                            • Re: 5 | Error  | Unable to get archive data from source PI server
                              Rhys Kirk

                              Possibly source PI Server archive corruption, or unresponsive Source PI Server PIArchss, PISnapss, PIBasess.

                                • Re: 5 | Error  | Unable to get archive data from source PI server
                                  marco.zoccoli

                                  thanks for the information.

                                   

                                  But I think that it is not corrupt because the development environment that is always connected to the PI Server, it works fine.

                                   

                                  What tests I should run to verify unresponsive Source PI Server PIArchss, PISnapss, PIBasess?

                                   

                                  here are other messages that I see in the log

                                   

                                  Scan class 1: Starting history recovery.

                                   

                                  -HR-PERIOD is 48.00 hours: Data recovery begins at 16-Feb-14 15:25:08 (local time)

                                   

                                  -HR-INTERVAL 1 of 2: Data retrieval ending at 17-Feb-14 15:25:08

                                   

                                  -Error -10733 returned from piar_getarcvaluesx(1) call to source PI server PISRVQA.RISORSE.ENEL

                                   

                                  -Unable to collect data until error is cleared

                                   

                                  -Scan class 1: History recovery failed to complete successfully due to errors.

                                   

                                  -History recovery will be attempted on each subsequent scan.

                                   

                                  -History recovery messages will be suppressed until errors cleared.

                                   

                                  Thanks a lotttttttttt

                                   

                                  Marco

                                    • Re: 5 | Error  | Unable to get archive data from source PI server

                                      Hello Marco,

                                       

                                      The issue you are experiencing should be investigated by OSIsoft Technical Support. A while ago we have started a new procedure which is intended to improve the experience for our vCampus users. As opposed to asking you to open a Tech Support call, we are turning cases like yours into Technical Support calls internally. The Technical Support Engineer taking the case, contacts the vCampus user proactively. With your specific case for some reason our procedure doesn't work. Please accept our apology for the inconvenience.

                                       

                                      While we are fixing communication issues you may want to reach out to Technical Support on your own. Please let us know when you've opened a call yourself, so we can attempt to avoid confusion.

                                       

                                      I've checked the log you attached in the meantime but unfortunately, there's too few information to understand the nature of your issue.

                                       

                                      Error [-10733] translates "PINET: RPC Resolver is Off-Line." An RPC call was made to a PI Subsystem but not taken by the receiving party indicating the subsystem is off-line. The piar_getarcvaluesx() call should be serviced by PI Archive Subsystem. The call failed against the source PI Server PISRVQA.RISORSE.ENEL. This can be a communication error or an issue with PI Archive Subsystem on the source PI Server as suggested by Rhys.