Goodtech

AF SDK target framework

Discussion created by Goodtech on Feb 19, 2014
Latest reply on Apr 16, 2014 by aantouf

It seems to me that the .DLL in \PIHOME\AF\PublicAssemblies\4.0 is built with .NET 4.5 as its target instead of .NET 4.0 as is claimed in documentation and training videos.

 

When I try to build the project with 4.0 as a target framework, it won't build, but it builds when I target 4.5. Unfortunately, the project is part of a solution with 90+ projects that all target .NET 4.0, so building it for .NET 4.5 isn't really an option. Has anyone else experienced this?

Outcomes