rsun

Is there any plan to upgrade the PI JDBC Driver for Linux to support OpenSSL 1.0.1e?

Discussion created by rsun on Apr 4, 2014
Latest reply on Apr 9, 2014 by michaelh

Does the current version of PI JDBC Driver support OpenSSL1.0.1e? If not, is there any plan to upgrade the PI JDBC Driver for Linux to support OpenSSL 1.0.1e. If there is, when? I have a customer upgraded to OpenSSL1.0.1e library and PI JDBC driver no longer working.

 

From the release note, it stated that it support OpenSSL 0.9.8 and OpenSSL1.0.0

 

PI JDBC Driver on Linux requires:

 

 

  • Java Runtime (Java SE Runtime Environment 6 or higher)
  • OpenSSL 0.9.8 or OpenSSL 1.0.0

 

 

Further dependencies are based on the OpenSSL version being used:

  • OpenSSL 0.9.8
  • libstdc++ 4.2, including GLIBCXX_3.4.9 (standard GNU C++ shared library)
  • glibc 2.4 (standard GNU C shared library)
  • libgcc 4.1.2 (standard GNU C Compiler runtime library)
  • OpenSSL 1.0.0
  • glibc 2.11

 

Outcomes