dpilc

PI OLEDB: frequently occurring errors

Discussion created by dpilc on Apr 29, 2014
Latest reply on Oct 3, 2018 by vkaufmann

I have problem with frequently occurring errors which occurs in time very irregularly:

An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] [...some_tag...] Failed to retrieve events from server.  [-10722] PINET: Timeout on PI RPC or System Call.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] [...some_tag...] Connection to the server lost.  [-10734] PINET: Broken Connection.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] Call to retrieve points failed.  [-16212] Timeout attempting to get non-exclusive lock.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] Connection to the server lost.  ".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] Connection to the server lost.  [-10734] PINET: Broken Connection.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] Too soon to attempt reconnection.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "[PI SDK] Unable to open a session on a server. [-10758] Failed to create remote connection.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80004005  Description: "Unknown error.".
An OLE DB record is available.  Source: "PIOLEDB"  Hresult: 0x80040E14  Description: "Catalog name 'piarchive' is invalid.".

I would be very grateful for help.

Outcomes