VCampus-METCO

Registering of AFDeliveryChannel fails (Owning assembly for support assembly ' ' is not defined.

Discussion created by VCampus-METCO on Oct 29, 2014
Latest reply on Oct 29, 2014 by VCampus-METCO

I developed a custom Notifications Delivery Channel to create measurement documents in SAP using WebServices with the following architecture:

  •  PI Server 2012
  •  PI-AF 2014 (Server + Client)
  • Notifications 2012
  • AF / Notifications Developer Tools 2012
  • Visual Studio 2010 SP1
  • Windows 7 (32-bit)

My Delivery Channel was based on the sample HTML delivery channel available through VCampus.

 

The Delivery channel registers fine with the regplugin tool. 

 

When I try to register on the target machine which has the following architecture

  • PI-AF 2010 R3 Server
  • PI-AF 2012 Client
  • Notifications 2012
  • W2008 R2 – Notifications set to run 32 bit mode.

 I get the error:

 

 "Owning assembly for support assembly ' ' is not defined. May need to specifiy the owner using the 'Owner' argument."

 

I  have looked on VCampus which says that this error message is displayed if the plug-in is not inherited from one of the following PlugIn types (AFDataReference, AFTimeRule, AFAnalysisRule or AFDeliveryChannel)), it thinks that it is a standalone support assembly. However my Delivery Channel is inherited from the AFDeliveryChannel class.

 

 I tried to register on a test 2008 R2 VM with the same version of AF client/server/notifications as my development environment and that worked fine – as one would expect.

 

 I then thought that the problem may be because the version of AF on the target was earlier than the version on my development machine. So I set up a test 2008 R2 VM machine with the same version of AF Server (2010 R3)/ Client (2012) etc as on the target environment and copied on my DLL. I was able to register it successfully.

 

 So I am a little confused as to what the problem is. Does anyone have any ideas why it won't register correctly. Do I have to put the DLL in a certain folder? On the systems where registration worked it did not matter where the DLL was registered.

 

 

Outcomes