3 Replies Latest reply on Jul 8, 2015 12:42 PM by dng

    PI Data Service Exception [OSISOFT.AFSDK], Cannot Connect to  server 'XXXX'.  It may be impersonated client user account  cannot be delegated to  the remote AF server.

    Srinivas
      Hi, I am trying to resolve the below since last week and could not succeed.. "PI Data Services Exception [OSISoft.AFSDK] Cannot connect to server 'XXXXX'. It may be that the imperosnated client user account cannot be delegated to the remote AF Server.: Here is the deployment. Share Point server 2013 and PI webparts 2013 SP1 + PI Webparts services installed on the same server ( Share Point is running on 80 port and SP is configured as Farm)... Am trying to create a relational datasource to AF so that data can be displayed in the PI table webpart and pass the context from tree view to PI table webpart.. On the same share point page, tree view web parts being displayed correctly ( i.e account is delegated correctly  to AF server). where as in the PI table webpart,  the above error message is getting displayed.. Here tried using the basic delegation and constrained delegation.in the both case same error message displayed. On other hand, There is another server and exact same setup , Share Point is configured as standlone .. basic delegation is working fine with out errors.. Even without creating the SPN for PI webparts services application pool account. this is strange and it is working fine.. for the table delegation is not happening and see the ANONYMOUS LOGON IN THE AF server event viewer thought I properly configured the delegation as per the manual. Any help/advice resolving this will be greatly appreciated.. regards, Srini