AnsweredAssumed Answered

Mixed Mode Assembly with ACE

Question asked by TimCarmichael Champion on Feb 24, 2015
Latest reply on Feb 25, 2015 by Eugene Lee

This morning, patches were pushed to my computer and I started receiving the following message when trying to debug ACE code.

Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.

 

The application was working until the patches were installed; because it was a corporate push, I'm not sure of what was changed.

 

The ACE application is written in VB.NET, .NET Framework 4.0, compiled against x86 as the target CPU.

 

References are:               Version           Runtime version

AFSDK                   2.0.0.0               2.0.50727

PIACENet              2.1.50.4             2.0.50727

PISDK                   2.0.50727           1.4.0.0

PISDKCommon       2.0.50727           1.4.0.0

PITimeserver           2.0.50727           1.4.0.0

System                   4.0.0.0               4.0.30319

System.Data           4.0.0.0               4.0.30319

System.XML           4.0.0.0               4.0.30319


Other similar ACE modules that previously worked (no changes made today) are receiving the same error with trying to debug.


Any ideas?

Outcomes