AnsweredAssumed Answered

How to set-up the PI Excel Add-In that the command "PICalcVal()" is not always executed?

Question asked by Bastian_DE on Nov 15, 2017
Latest reply on Nov 23, 2017 by Bastian_DE

Hi all,

 

i use the PI Excel AddIn to implement plant data in a Excel tab.

I use the PiCalcVal() command and import quite a couple of datapoints (around 2000 tags).

 

I have the problem, that PI always wants to update the data (but this is not necessary). After every equation or caluclation i implement in the Excel sheet, even if the PI-data is not needed/used for this equation - PI wants to update the data.

This is really annoying, not necessary and slows down the workflow significantly.

 

Is there any possible option, that PI should only update the data every (for example) hours or so? I tried to increase the "Interval" value (under setting - automatic update) - but this had no impact.

 

Any tips how to solve this problem?

 

Thanks and kind regards

Bastian

Outcomes