5 Replies Latest reply on Jan 10, 2018 9:08 AM by AdrianPD

    error checking in from PI System Explorer

    AdrianPD

      In PI System Explorer, I created some templates in the Library and then checked them in without a problem.

       

      I then went to the Elements navigation bar and created some elements from these templates. Once I had done this, I tried to check in again. This time, however, the checkin fails with this error:

       

       

      Why does this suddenly happen where the checkin succeeded for the templates?

       

      I went back to the library navigator and modified the templates, then tried to checkin those changes. Now, even the template checkin fails with this error:

       

       

      Something strange happening here. I had just a few minutes earlier been able to checkin templates but now get errors

       

      Why is this?

        • Re: error checking in from PI System Explorer
          AdrianPD

          Some more information on this:

           

          I found I was getting the second error I show above for anything I did on System Explorer. For example, even clicking on the Database menuitem threw that error.

           

          I ended up terminating PI System Explorer and restarting it and that allowed me to continue with checkins.

           

          I still need to know what happens here. Why do I need to restart System Explorer?

            • Re: error checking in from PI System Explorer
              rschmitz

              Hi Adrian,

               

              On first glance it looks to be a network interruption between your client machine and the AF Server which occurred between the time you checked in the templates and the time you attempted to check in the Elements based on those templates. It's possible that interruption happened and the socket connection couldn't recover properly and that's why you got the timeout errors (and I suspect the check-in errors as well). Reopening PI System Explorer would initiate a fresh connection which would explain why that fixed it. Do you see anything in the Event Viewer Logs on either your machine or the AF Server which might corroborate that theory?

               

              Is this something that frequently occurs or is this more of a one-off situation?

               

              Cheers,

              Rob

                • Re: error checking in from PI System Explorer
                  AdrianPD

                  Thanks Rob

                  Actually it is reproduceable. I startup System Explorer, make a mod, check it in. It works this far. Then the next attempt to check in fails.

                  If I then repeat the above, the same thing will happen.

                    • Re: error checking in from PI System Explorer
                      rschmitz

                      Ok, do you get the first error (timeout) or the second (object not checked out by the requesting user) when you reproduce it? Do you see anything in the Event Viewer Logs > AF on the AF Server? Is this happening for other users or just yourself? If it's for just yourself does this occur on other machines as well?

                       

                      I think in the long run, this will be solved more quickly by contacting our tech support group directly, but this ought to give us a better sense of what's going on.

                       

                      --Rob

                        • Re: error checking in from PI System Explorer
                          AdrianPD

                          Hi Rob

                          Thanks for the help on this. Much appreciated.

                          To answer your questions, the timeout is the one that reoccured reliably. I don't see anything on the logs. Just this for PI: ANDataCache.ReportStatistics[]: ANDataCache:ANPeriodicTimeClassManager Summary:: CacheUpdateTime:10-Jan-18 00:31:49 Inputs:0 Outputs:0 EventsCached:0 EventsProcessed:0 DataAccessCallsFromCache:0 DataAccessCallsFromSource:0 MaxUpdateDuration:00:00:00.2474115 LatestUpdateDuration:00:00:00.0000582

                           

                          So, that all said, I have to also say that today the error is not happening. I expect your initial assumption that it was some network issue must be the reason

                          Regards
                          Adrian