6 Replies Latest reply on Oct 24, 2018 3:01 AM by YMax

    Shutdown Advise Failed: Unknown Error (80040202)

    YMax

      Hello guys!

      I broke my head while looking for the cause of the error. I created a new instance of OPC DA Interface, on the same node where everything is already working. What I mean:

       

      1. There is the Server1, where:

           - OPC DA Server1 is installed

           - local user account svc-interface is created

           - DCOM settings are configured as required

           - Policy settings are configured as well

       

      2. There are Node1 and Node2, where:

           - PI OPC DA Interface is installed

           - local user accounts are created on the both Nodes. Accounts have the same name and passwords like on the Server1

           - DCOM settings are configured as required

           - Policy settings are configured as well

           - InterfaceInstance_1 and 2 are running under accounts mentioned above, they are have identical settings, connected to OPC Server_1 successful and reading data well (because all needed ports are opened, all needed exceptions are created on the Firewall, there all permissions to files and folders, etc.)

           - Interfaces are configured as Failover, and work good several years without errors. They where restarted many times, and no any issues.

       

      Now I created the 3rd instance on the Node2 absolutely the same as the first and second instances (OPC Server on the Server1 is data source as well), but when I run it, I get error messages listed below. According to these messages I see that interface connects successful, but after that connection failed.

       

      4. Disconnecting from OPC Server

      3. CheckConnection disconnecting thread bla bla bla

      2. Shutdown Advise Failed:: Unknown error (80040202)

      1. Connected to OPC Server

       

      I had double check all settings everywhere, but didn't find where the problem is hiding.

      I hope someone knows how to fix it.

       

      Thank you.

      Regards,

      Maxim.