AnsweredAssumed Answered

OSIsoft.AF.PI.PIAuthenticationException: Can not connect to the PI Data Archive.

Question asked by AlvaroZambrano on Apr 4, 2019
Latest reply on Apr 5, 2019 by LalBabuShaik

Hi all,  I'm trying to develop an application with python that uses the AF data. For this, I used the AF SDK but it is always delivering the following error. 


"OSIsoft.AF.PI.PIAuthenticationException: Cannot connect to the PI Data Archive. Windows authentication trial failed because the authentication method was not tried. Trust authentication trial failed because insufficient privilege to access the PI Data Archive.

   en OSIsoft.AF.PI.PIException.ConvertAndThrowException(PIServer piServer, Exception ex, String message)

   en OSIsoft.AF.PI.PIServer.RemoteConnect(AFConnectionPreference preference, NetworkCredential credential, PIAuthenticationMode authenticationMode)

   en OSIsoft.AF.PI.PIServer.InternalConnect(Int32 numRetries, IWin32Window owner, AFConnectionPreference preference, NetworkCredential credential, PIAuthenticationMode authenticationMode, Boolean checkConnectingAsSameUser)

   en OSIsoft.AF.PI.PIServer.AutoConnect(Boolean allowDirectConnect, Boolean force)

   en OSIsoft.AF.PI.PIPoint.FindPIPoint(PIServer piServer, String pointName)"


I am sure that I configured the trust in the archive server. I have two days with this problem and I have not been able to solve it.


Someone has an idea of how this problem could be solved?.  Thank you.