CarlB

Can't access PI Vision utility page.

Discussion created by CarlB on Feb 4, 2020
Latest reply on Feb 4, 2020 by jswartzentruber

Hello all,

 

I'm having some issues with the PI Vision Display Utility since our upgrade to 2019. PI Vision itself works great, including the admin pages. We have PI Vision set up to use Kerberos delegation and Windows Authentication. However, whenever I try to visit the Utility URL (https://<servername>/PIVision/Utility/) I either get prompted for a username and password or get a 403 Forbidden error. I get the same results regardless of the type of URL (servername, fqdn, localhost) or browser.

 

I've updated the Utility AppPool to use the same service account as the other two PI Vision AppPools and restarted IIS for good measure. The service account has SPNs for HTTP/<servername> and HTTP/<dnsname>. Delegation looks correct, the service account has delegation rights to the AF Server and the the PI DA servers. Again, I can get to the admin pages in PI Vision without issue, so unless there are additional SPNs or Delegation needed for the Utility page, I don't think it's a Kerberos issue...I think. I'm still not confident in my understanding of kerberos delegation.

 

I've also verified that my user is in the PI Vision Utility Users group on the PI Vision server. I'm also in the PI Vision Admins and PI Vision Users groups. My user also has full admin rights within PI (I'm a member of the Administrators Identitiy).

 

And finally, when I run the stand alone utility in the \Program Files\PIPC\PIVisionDisplayUtility folder I can connect and see a list of displays.

 

I'm having this issue on all three of our PI Vision displays (one dev, and two production behind a load balancer). Anyone have any ideas?

 

Thank you!
Carl

Outcomes