AnsweredAssumed Answered

"Registry key not found" error when creating Pi Points using AF Sdk / Crearing Pi Points using AF Sdk

Question asked by VarbanVarbanov on May 26, 2014
Latest reply on Mar 3, 2017 by SergeyKoreshkov

Hi, I'm trying to create Pi Points using the instance AF SDK Method

public PIPoint CreatePIPoint(string pointName, IDictionary<string, object> attributeValues = null)  of PIServer class. I got an error :

"Registry key not found for <server name>".
Error code : -2147176694 
Stack trace :


at PISDKRegistryLib.ISDKRegCollection.FindStringItem(String ItemName)
at OSIsoft.PI.Configuration.Schema.PIServerAliasDirectory.<>c__DisplayClassa.<ContainsKey>b__9(ISDKRegCollection aliases)




I've tried this with three different Pi Servers, the error is the same. All servers can be accessed using Pi System Explorer. This could be related to recent installation of AF Server client 2014. The version of PI SDK is 1.4.2; The version of AF SDK is and I tried with this currently installed and also with the older verdsion of AF SDK.

Please help me to find a solution for this problem!


Also could anyone provide some documentation (or an alternative way) for creating Pi Points using AF Sdk - or at least the list of string keys in the dictionary parameter of the method which can be used and the corresponding PiPoint attributes (It is a bit difficult sometimes to imagine the exact name or the object need to be passed as value of the dictionary entry). The examples I've found are very basic and I need to create for example Digital Set, Point Source. Locations, etc of the Pi Point.